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Q2P Distribution List Emails 
 

The Q2P Communications document is simply a collection of emails that have been sent to WisDOT’s 
Q2P email list (with unsubscribe etc. information deleted). 

 

Sent: Thursday, September 8, 2016 
Subject: WisDOT Q2P Update – Thursday, September 15th 
To: DOT Q2P Mailing List 
From: dotq2p@dot.wi.gov 
Date: September 15, 2016 

You are receiving this message as a subscriber to the Q2P email list. Please visit 
http://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-
q2p.aspx or use the link at the bottom of this message to unsubscribe, if desired. Thanks. 

Important Notices 

On Thursday, September 15, 2016, an update of Q2P will be pushed to your workstation. If you 
have modified any of the existing files or stored any files in the C:\Q2P directory (or 
subdirectories) please back them up as the update to Q2P may completely replace the existing 
C:\Q2P directory and files. Please save your work and log out of your workstation at the end of 
your workday on September 15th to reduce the risk of potential data loss during the installation. 

Existing Q2P files will be able to utilize updated macros; however, the bid item list from the 
2017 Standard Specifications will not be reflected in these existing files, and will only be seen in 
the creation of a brand new Q2P file. Any modifications to bid item lists in existing Q2P files 
will need to be manually entered. 

Existing PowerPoint plan sheets will be unaffected. 

Simply copying the C:\Q2P directory to a new workstation is insufficient for Q2P to function. 
Important system files must be installed. Users need to contact the DOT Computer Help Desk for 
installation to a new workstation. 

Fixed/Updated in this Version 

The calendar used for selecting the current date has been revised; this change will also remove an 
error seen by many users when activating the macros in the program. 

A compatibility error with Estimator version 2.14a-1 regarding the import and export of data has 
been resolved. 

http://lists.wi.gov/t/1208117/1956129/8424/5/
http://lists.wi.gov/t/1208117/1956129/8424/5/
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A macro for XML output to AASHTOWare Project Preconstruction has been added. 

Important Reminders 

Please note that directly editing the miscellaneous quantity item worksheet template is still very 
much discouraged in Excel 2013 as it was in Excel 2007. The only possible exception to this is 
that it MIGHT be okay to edit the template prior to creating ANY miscellaneous quantity 
worksheets (i.e. before a single item is added to the project). Once an item (and its worksheet) 
have been added, then the template should not be further revised. 

Remember the limitation and potential problems associated with using Sort on filtered lists or 
non-contiguous data and instead always use Number Filters. 

Please do not ever enter quantity data directly onto the Bid Items worksheet. Even if the item 
doesn't need a miscellaneous quantity table in the plans, or you just have bid item totals from an 
outside source (such as permanent signing, traffic signals, lighting), the total still needs to be 
entered onto the individual item's miscellaneous quantity worksheet. 

Please contact your local Q2P power user or dotq2p@dot.wi.gov with any questions. 

 

Sent: Tuesday, March 11th, 2015 
Subject: Update to Q2P Template and Macros on March 12, 2015 
To: DOT Staff 
From: The Bureau of Information Technology Services (BITS) 
Date: March 10, 2015 

On March 12, 2015, an update to the Q2P template and macros will be pushed to WisDOT workstations 
that have an existing Q2P installation.  Please leave your workstations at the logon screen to receive this 
update.  A reboot is not expected as part of this update.  

Please remember to never store working files in C:\Q2P (or its subdirectories) as they might be deleted 
during an update. 

The updated macros will be used by existing Q2P files; however, it will not update existing files to 
include items from the 2015 Standard Specifications.  Those must be manually added to existing files as 
needed.  Also, the existing PowerPoint plan sheets will be unaffected. 

New/fixed in this version 

The bid items from the 2015 WisDOT Standard Specifications have been added, with outdated items 
flagged as retired, or deleted as appropriate. 

The miscellaneous quantity item worksheet template has been altered to include less lines in categories 
other than 0010 to ease in use with projects with fewer categories.  The column widths have also been 

mailto:dotq2p@dot.wi.gov
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adjusted to allow for more flexibility when importing into PowerPoint, and they have been center 
justified to allow for narrower columns in between columns with data. 

You are now able to create miscellaneous quantity item worksheets for ASP items using the “Add One or 
More Miscellaneous Quantity Sheets…” dialog box. 

When creating a pjiport.dat file for TRNS*PORT, Q2P will now allow you to select the region and work 
type.  The work types have been updated to match FDM Chapter 19. 

The Q2P website on the WisDOT website is now directly accessible from the Q2P application, by 
selecting “What’s New” from the Help command in the Add-Ins tab. 

Known Issues 

When testing this release, users reported they could not access the “Combine/Add Related Items…” 
command from the Data menu in the Add-Ins ribbon upon using the template for the first time.  This 
command is still accessible through the context-sensitive right mouse click menu, and can be restored to 
the Data menu of the Add-Ins ribbon by using the Add-Ins > Project > Refresh Toolbar command. 

 

Important Reminders 

Please note that directly editing the miscellaneous quantity item worksheet template is a discouraged 
workflow.  Testing by Q2P power users has shown that significant problems arise if the template is 
revised after an item (and its corresponding worksheet) has been added. 

Please do not ever add quantity data directly onto the Bid Items worksheet.  Even if the item does not 
need a miscellaneous quantity table in the plans, or you just have the bid item totals from an outside 
source (such as permanent signing, signals, lighting, etc.), the total still needs to be entered onto the 
actual item worksheet.  This affects the ability of the program to export accurately to Estimator and 
TRNS*PORT. 
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Remember the existing limitations and potential problems associated with using Sort on filtered lists or 
non-contiguous data.  The number filters available in the Cost cell drop-down menu can provide similar 
functionality.  Guidance for this method can be found in the Q2P communications document found on 
the WisDOT Q2P website. 

Q2P Support 
Email: dotq2p@dot.wi.gov 

If you have any questions regarding the details of this update, please contact the DOT IT Service Desk at 
(608) 266-9434 or 1-800-362-3050. 

Thank you! 

Bureau of Information Technology Services (BITS) 

 

Sent: Friday, September 20, 2013 2:36 PM 
Subject: Q2P - Guidance on the use of Sort; fix for incorrect bid item number cell formatting; 
and miscellaneous tips/info 
 

Please review the following guidance for Quantities 2 Plans: 

• Users have been wanting to use the Excel command Sort to quickly view the items making up 
80% of their project cost. There are some limitations of using Sort on non-contiguous data 
and/or filtered lists that some users are not aware of and this can cause issues with viewing the 
data in Q2P. Due to these limitations it is recommended that Sort is not used within Q2P. The 
types of errors that can be introduced to a project file by using Sort can result in incorrect bid 
data being made available to contractors or erroneous price data being used for the engineer’s 
estimate. In the worst case, it may not be possible to award the project after the letting and it 
would have to be re-let at a later date. 

 
o When using Sort, the command will only sort data that is “connected” to the original 

selection. If there is a blank column separating data, then the sort selection will not be 
expanded automatically to include that data. 

 

o If Sort is run on data that is part of a filtered list, Excel will not expand the selection to 
include contiguous data IF it is not part of that filtered list. In Excel, columns with data 
that are part of a filtered list have the drop-down arrow in a cell, as columns A-G, row 
12 have in Q2P. Therefore, even if there is continuous data in row 12 across to column 
K, the data in column K will NOT be sorted with a Sort of column G data. Also, if a Sort 
on column G is not immediately undone via Undo, but instead “undone” by sorting on 
column B [item number], then if there was an error in the original bid item number list 
order (likely from manually inserting a new item) then the data in column K will not 
match the correct item, (from the original error down). 

 

mailto:dotq2p@dot.wi.gov
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o When using Sort, the links on the individual item worksheets do not get updated, 
therefore the item description, number and units will be incorrect. The Update 
Quantities [Q2P] command should fix the links, but there could be miscellaneous 
quantity sheets with errors that might go unnoticed. 

 
o What to do then? Use Number Filtering instead. On the column G drop-down (in row 

12), Number Filters > Top 10… and change to use Top | 20 | Percent. This will filter the 
items down to 20% of the total number of items, starting at the highest value (in column 
G). It will not sort them by value, but this will keep data to the right of column G in the 
correct order. To remove the filter, simply select the drop-down again in column G and 
select Clear Filter From “COST”. Adjust the 20% as desired to display ~80% of total 
project cost. As an alternative to number filtering, the AutoFilters can also be extended 
to include data to the right of column G, but this will still include the same link issues on 
the item worksheets and is not recommended. In addition, the Sort selection can be 
manually set by the user to include all the appropriate data, and the command then run 
from Data > Sort (rather than the AutoFilter drop-down), however this is still dangerous 
to do for the reasons listed above and is not recommended. 

 

o We are looking into options for disabling Sort in Q2P while retaining the ability to use 
Number Filters. In the meantime, the user will need to be aware of the problems 
associated with Sort and avoid its use, or exercise extreme caution. 

 

• There has been an issue with Q2P regarding the formatting of the item numbers in Colum B of 
the Bid Items worksheet. They are currently formatted as General, which means that if a cell 
containing an item number ending in zero(s) is entered into [for editing], the trailing zeros will 
be dropped upon leaving the cell, and the number will be aligned to the right. The issue severity 
depends on when the trailing zeros get dropped. If they are removed prior to the bid item 
worksheet creation then there are more issues than if it is after creation. 

 

o To fix this formatting in the Q2P template file, navigate to C:\Q2P, and right-click and 
select Open to open the Q2P.xltm file (if the user simply double clicks the shortcut or file 
instead, the template will create a new XLSM file instead opening the XLTM template 
itself for editing). Any existing project files will need to be manually fixed as well. 

 

o The range B13:B2267 (or through the last item number of the user’s project file) must 
be formatted as Text and not General. One simple way of highlighting a range such as 
this is to use the Go To command, via F5 or Ctrl+G and enter in the range. Next on the 
Home tab, Number panel, select the main drop-down and change to Text, and deselect 
the range (by selecting elsewhere in the worksheet). Do not change the formatting of 
the entire column to Text. Check to see if any worksheets were created with the zero(s) 
dropped, and update the name as appropriate. 
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• Do not ever enter any quantity data directly onto the Bid Items worksheet. Even if the item 
doesn’t need a miscellaneous quantity table in the plans, or you just have the bid item totals 
from an outside source (such as permanent signing, signals, lighting, etc.), the total still needs to 
be entered onto the actual individual item worksheet. Do not delete worksheets for items that 
may seem to be not needed (due to the use of Summary Sheets, etc.). Every bid item needs to 
have its own worksheet in Q2P, regardless of whether or not that worksheet table is included in 
the miscellaneous quantity sheets, otherwise the export to trns*port and reports will not 
include the quantity. 

 

• The item 460.4110.S should be named “Reheating HMA Pavement Longitudinal Joints” – the 
word Pavement is missing in the Q2P item description. This does not create an issue in trns*port 
since only the supplemental portion of the item description text is exported from Q2P; however, 
to have the item description correct on your miscellaneous quantity sheets it needs to be 
manually corrected. Update the template as noted above, and update any working files if the 
item will be used. 

 

o This issue has been corrected in trns*port and will be in the next Estimator update. The 
STSP index.xlsx file has also been corrected to have the current bid item number. 

 

• There is an issue that we are currently tracking but do not have a fix for at this time: when a bid 
item is unlinked from a Summary Sheet (created from combining items onto one worksheet) 
occasionally some garbage data gets inserted into row 1,048,576. This will cause some 
performance issues in the file. As a workaround, if you notice after unlinking an item the 
scrollbar on the Summary Sheet becomes very small, select all the rows (down to the very end) 
under the worksheet’s visible data and right-click delete. When the file is saved, the scrollbar 
should appear normal (for the amount of visible data on the worksheet). 

 

-Q2P Support 

 

Sent: Friday, June 21, 2013 4:53 PM 
Subject: WisDOT Q2P Update - Monday, June 24th 
 

During the evening of Monday, June 24th, an update to the Q2P template and macros will be pushed to 
WisDOT workstations that have an existing Q2P installation. Please leave your workstation at the logon 
screen to receive this update. A reboot is not expected as part of this update. Contact DOT Q2P or DOT 
Computer Help Desk with questions. 

Please remember to never store working files in C:\Q2P (or its subdirectories) as they might be 
deleted during an update.  
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The updated macros will be used by older, existing Q2P workbooks; however, existing workbooks will 
not automatically be populated with items from the 2014 specifications. Those items must be manually 
added to existing files as needed. 

New/fixed in this version 

The bid items from the 2014 WisDOT Standard Specifications have been added, with outdated items 
flagged as retired, or deleted as appropriate. 

New item worksheets now default to five categories instead of three. 

The work types in the Export Estimate dialog have been updated and the district field has been disabled, 
to match Estimator output. 

Summary worksheets created with a “-c” in the worksheet name (e.g. 520-side-culverts) will now appear 
in the list of existing summary sheets in the related dialog boxes; however, summary sheets ending in “-
c” (e.g. 520-side-c) still need to be avoided. It is also now recommended to name summary sheets with 
only hyphens to avoid some possible errors with creating the trnsport upload file. Existing summary 
sheets named in the “520.side-culverts” format do not need to be edited unless problems are 
encountered. 

The Q2P User Guide shortcut links to an updated version (June 5, 2013). It includes some expanded help 
for common errors. Please refer to it for help with right-click paste issues; freezes associated with using 
AutoFilter dropdowns to Sort columns; and guidance on what characters must be kept out of summary 
worksheet names. 

Also, please note that directly editing the miscellaneous quantity item worksheet template is now very 
much discouraged as the update to Excel 2007 has found that process to be more problematic than with 
previous versions. 

 

-Q2P Support 
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