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 INTRODUCTION 
Quantities 2 Plans 
Quantities 2 Plans (Q2P) was developed by the Wisconsin Department of Transportation to create a single 
repository of construction bid item data for maintaining a live link between the engineer’s estimate, quantity 
calculations, and the construction plan miscellaneous quantity (MQ) sheets. Q2P is a Microsoft® Excel® macro-
enabled workbook-based application that contains all the current bid items (from the WisDOT Standard 
Specifications for Highway and Structure Construction). 

The MQ plan sheets are created in Microsoft® PowerPoint® and link to Q2P. The data is updated by design staff 
from scoping phase through PS&E, when the estimate is uploaded into AASHTO Trns•port PES® or AASHTOWare 
Project Preconstruction (AWP Preconstruction). When a project estimate is submitted to Central Office at PS&E 
phase, Q2P is no longer considered the official engineer’s estimate. At this stage, region policy dictates whether 
or not Q2P is kept current with the changed data in Trns•port PES or AWP Preconstruction (from PS&E review 
revisions, addenda, etc.) 

The WisDOT Q2P Support Committee maintains Q2P (the workbook and macros), and provides support via the 
DOTQ2P@dot.wi.gov (DOT Q2P) email address. The WisDOT Estimating Group is an additional resource that 
provides best practices and information related to construction cost estimating. 

Visit http://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx to 
subscribe to the WisDOT Q2P email list for Q2P news or to find the name of power users in your region for support. 
Notifications for updates, or tips & tricks, etc. are shared via this distribution list. 

Quantities 2 Plans contains some menu items that have been disabled due to incompatibility with Office 2013, or 
because they are related to a legacy workflow. 

Confidentiality Notice 
Engineering estimates are always treated as confidential before, during and after the letting by WisDOT. Engineer 
estimate data should not be released outside of WisDOT with the exception of the Federal Highway Administration 
and engineering consultants working directly for WisDOT. The State Transportation Agency (i.e. WisDOT) policy is 
further explained in Appendix C. 

When sharing information with the public, or when a general estimate is required in a project report (e.g. the 
Work Zone Transportation Management Plan), obtain the project estimate range from region planning section’s 
Public Report. 

  

mailto:DOTQ2P@dot.wi.gov
http://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
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 USING QUANTITIES 2 PLANS 

1. Before You Get Started 
Quantities 2 Plans (Q2P) requires system files to be installed.  WisDOT staff will need to contact the DOT IT 
Service Desk for installation of the necessary system files.  Simply copying the C:\Q2P in a disk image or from 
another user will not be adequate for the application to operate. 

Q2P requires a C:\temp directory and will create a C:\Q2P\temp directory as needed. 

The workbook template (XLTM) and macros (XLAM) must be in C:\Q2P on Windows® XP and Windows® 7. 
The project working file (XLSM) should be stored in your project estimate folder, or where your region’s policy 
dictates. 

Q2P updates are pushed to WisDOT staff’s workstations by IT. These updates will delete (and 
recreate) the entire C:\Q2P directory (and its subdirectories). 

Q2P is currently supported under Microsoft® Office 2013 (32-bit) on Windows 7 (32-bit version). 

Q2P is not expected to run under any 64-bit version of Office as Microsoft does not provide 64-bit versions of 
the necessary (ActiveX) Common Controls. Q2P can also possibly run on a 32-bit version of Office on 
Windows 8 (64-bit), provided installation of the 32-bit Common Controls is allowed. This environment is 
currently untested. 
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2. Begin a New Project – Entering Project Information 
1.  Open the Q2P.xltm workbook and enable the macros.  

 

Figure 2.1 The Excel launch icon for Q2P. 

If security warnings display (Figure 2.2), enable the Q2P macros. Alternatively, to avoid these 
messages in the future, the Q2P application directory can be added as a trusted location and 
macros can be allowed to run without prompt. See the Revising Security Settings in the 
Miscellaneous Helpful Information section for more information. 

 

Figure 2.2 Security warnings. 

Once the macros are enabled, the ADD-INS tab will appear on the ribbon (Figure 2.3). This tab houses all 
of Q2P’s specific commands and functionality. 

 

Figure 2.3 Q2P-specific commands found under the ADD-INS tab. 

  



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 11 

2.  Verify the date of the WisDOT Standard Specifications. The example below uses the 2017 edition. 

 

Figure 2.4 Initial view of Q2P: The main “Bid Items” worksheet. 

3.  Save the workbook, using the 00000000_mqw.xlsm format, where 00000000 is the associated 
construction ID. Store the working file under your project estimate folder, or where your region’s policy 
dictates. A date or other version related text can be added to the file name (e.g., 12345678_mqw-
30REVIEW.xlsm). 

Never save the file in C:\Q2P as this directory is deleted and recreated during updates.  

4.  Enter all the project information, including those found at the bottom of the worksheet (Figure 2.7), 
which can all be obtained from FIIPS through Project > Funding… and clicking Category # 00n0 for more 
detailed information. The information in Q2P must match FIIPS information EXACTLY. 

Do not insert any new rows or columns or delete existing ones in the Project Information 
section (rows 1-12, columns A-I). Also, do not edit any table or field headings/labels such 
as “CONST. I.D.:”, “UNIT PRICE”, “CONSTRUCTION COST ESTIMATE”, etc.  

 

Figure 2.5 FIIPS menu navigation. 
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Figure 2.6 FIIPS project information 

Always use the dialog box to edit the category information and do not edit their headings (i.e. 
“Categories”) on the “Bid Items” worksheet. 

Never delete Category rows on the main “Bid Items” worksheet in Excel. If the category 
is not needed, select the blank entry at the beginning of the dropdown list. 

 

Figure 2.7 Categories, Federal Work Types and Funding entry in Q2P. 

If more categories are needed, clicking in the CATEGORIES column under the last used category will auto-
populate the blank row with a new one. If the desired work type is not in the list, type it in (50 – New 
Tunnel, for example). 

If a category row does not exist for a category on an item worksheet, Q2P will not recognize 
any data for that category in the bid items quantity totals. 

5.  Save the changes made to this workbook. Saving (to your local computer or a network drive) will enable 
Excel’s Autosave feature, reducing the risk of data loss in the event of a program crash. 
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3. Contingency Amounts 
Do not include construction contingencies in the Delivery Cost field in Q2P, and do not 
keep contingencies in the final estimate. 

In Q2P, a transient, mock bid item for contingencies is included for each category.  

The items SPV.0999.10, SPV.0999.20, etc. are used for this purpose. A separate contingency item is required 
for each category as the appropriate percentage will vary. Multiple items per each category can also be used, 
if separating the costs is desired (e.g. Traffic Control and Drainage both in Cat. 0010). 

Delivery cost is different than contingency amounts used in preliminary cost estimates; it is an estimate of 
staffing costs during the construction phase of a project.  Prior to final submittal of the cost estimate, this 
value should be coordinated with the delivery cost/percentage in FIIPS for the project. 

  

Figure 3.1 Delivery Cost entry.  
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4. Adding Bid Items and Worksheets 
Use either of the following workflows in 4.1, 4.2, or 4.3 to add bid items and worksheets. (Though it is not 
recommended, you may edit the bid item worksheet template. See Editing the Q2P Template for disclaimer 
and more information on how to edit the main worksheet template.) 

Using Excel undo/redo on the Q2P macros is not recommended. If a Miscellaneous 
Quantity Worksheet must be deleted after it is created, use the Q2P command. 

4.1 Using the “Project” Drop Down Menu (Inserts one bid item/worksheet at a time) 
1. ADD-INS > Project > Insert a New Item... will add the item and create the miscellaneous quantity 

(MQ) worksheet in one step.  Note that “Fixed Price” refers to a Pre-Established Price item from FDM 
19-5 Exhibit 10.6. Also note that any .S items created with these methods will not get color coded. 

 

Figure 4.1 Inserting a new item from the “Project” drop down menu. 

2. Once the “Insert New Item…” dialog box appears (Figure 4.2), fill in the fields appropriately.  

 

Figure 4.2 “Insert New Item…” dialog box. 

http://wisconsindot.gov/rdwy/fdm/fd-19-05-010e006.pdf
http://wisconsindot.gov/rdwy/fdm/fd-19-05-010e006.pdf
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3. Select “Insert Item” to finish. 

4.2 Using the Main “Bid Items” Worksheet (Inserts multiple bid items/worksheets at once) 
1. On the main “Bid Items” worksheet, verify the filter in A12 is set to “(Select All),” which displays all 

the rows. 

 
  
  

Figure 4.3 Excel filter button. Figure 4.4 Excel filter for viewing selected bid items. 

2. With all the bid items shown, scroll through the list and place an upper or lower case “x” in the far left 
column to mark the items you want to add. 

3. Select ADD-INS > Misc QTY Sheets > Create Miscellaneous Quantity Sheets for ALL the Marked Items 
“x” > for PowerPoint Plan Sheets Format. 

 

Figure 4.5 Create Miscellaneous Quantity Sheets command. 

In the event that this command becomes grayed out even though new items have been marked with 
an “X,” use the next method for inserting the MQ worksheets, or unload the Q2P-Macros.XLAM and 
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reload using the “Add-ins” dialog and then add an additional item. You can also use ADD-INS > Project 
> Refresh Toolbar. 

4.3 Using the Dialog Box (Inserts multiple bid items/worksheets at once) 
1. Select ADD-INS > Misc QTY Sheets > Insert One or More Miscellaneous Quantity Sheets… 

 

Figure 4.6 Selecting items from the dialog box. 

2. Use the dialog box to highlight one or more bid items. You can type part of the item description in the 
search bar to navigate to a particular item in the list. Select multiple bid items by holding down the 
“Ctrl” key and clicking different items.  

Use caution when holding the “Crtl” key to select multiple items. If you accidentally 
release the “Crtl” key while selecting an additional item, all previously selected items in 
the list will no longer be selected. 

3. Select “Create Misc. Sheets” to finish. 
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5. Items with Supplemental Descriptions 
Items that contain ( ) in their ITEM DESCRIPTION and SPV items are required to have a supplemental 
description entered, and a unique bid item number assigned. This is true for any item that has extra digits 
appended to the item number – item numbers must be unique if they are intended to pay for different things 
within the contract.  

For these special items in Q2P, the bid item numbers must be set up properly PRIOR to 
creating the item MQ worksheets.  

For contracts with multiple projects, remember that items that need a supplemental description, such as 
“Finishing Roadway (project),” need unique numbers for each project, for example:  

Finishing Roadway (01. 1234-56-78); Finishing Roadway (02. 9999-99-79) 

5.1 Using the Dialog Box from the “Insert One or More Miscellaneous Quantity Sheets…” 
Command 

If this “Add/Insert a new item to the list” button is used to add a new item, be aware that 
this only inserts a new item into the main Q2P bid item list, and the associated MQ 
worksheet needs to be created via additional steps.  

To access the same dialog box and create the associated MQ worksheet in one step, see 
workflow 4.1. 

1. Select ADD-INS > Misc QTY Sheets > Insert One or More Miscellaneous Quantity Sheets… > 
Add/Insert a new item to the list. 

 

Figure 5.1 “Create One or More Miscellaneous Quantity Sheets…” dialog box. 
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2. Once the “Insert New Item…” dialog box appears, fill in the fields appropriately.  

 

Figure 5.2 “Insert New Item…” dialog box. 

3. Select “Add Item.” 

4. Create the associated worksheet by following the workflow in either 4.2 or in 4.3. 

Occasionally the Excel worksheets will get out of numeric order when creating new MQ worksheets. Use 
ADD-INS > Data > Sort Sheets to reorder the worksheets. 

5.2 Using a Copy of the Template Bid Item 
1. On the main “Bid Items” worksheet, highlight the entire template row in Excel > right-click > Copy > 

right-click > Insert Copied Cells.  

Be sure and leave a copy of the original item in Q2P for future copying. The .S items 
that do not require a supplemental description are only used once and therefore do 
not need a copy retained. 

 

Figure 5.3 Using the Right-Click menu to insert a copy of the highlighted template row. 
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2. Append the item number with a decimal and (typically) two digits, and edit the description as 
appropriate (Figure 5.4).  

The item number suffix can and typically restarts at 01 for each different bid item. The numbers do 
not need to be sequential, and in some cases it is beneficial to leave a gap in numbering, especially 
for when multiple items will be defined in a single special provision, so additional sizes, types, etc. can 
later be easily added and grouped with like items. 

When editing the SPV item descriptions, the word “Special” is retained even though it would not 
be in the special provision language. 

 

Figure 5.4 Adding supplemental descriptions prior to creating miscellaneous quantity worksheets. 

(Some rows manually hidden for illustrative purposes.) 

The bid item supplemental descriptions are edited directly on the “Bid Items” worksheet which are 
linked to MQ worksheets. Include a period after the number in the supplemental description, e.g. (02. 
Cool Mix Asphalt Pavement Type 1). 

More information on naming ( ) and SPV items can be found in FDM 19-5, Exhibits 10.2 and 10.4. 

When inserting new items into the bid items list, always insert them between existing 
items, i.e., do not add an item below the last item in the list.  

  

http://dotnet/standards/fdm/19-05.pdf
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6. Deleting Bid Items and Worksheets 
Delete Sheets is used to delete both the MQ worksheets and comp sheets (See Comp Sheets for more 
information).  

Do not delete MQ worksheets using basic Excel functions (i.e., delete a worksheet by 
right-clicking the worksheet tab and selecting delete or by using Home [tab] > Cells [panel] 
> Delete [dropdown] > Delete Sheets). Using basic Excel methods will cause problems in 
Q2P.  

1. Select ADD-INS > Delete Sheets > Delete One or More Sheets to delete individual items from the “Bid 
Items” worksheet. Note that this is the same dialog as the ADD-INS > Project > Navigate, Print, or Delete 
Sheets… and that multiple items are selectable with Ctrl + Select.  

 

Figure 6.1 Drop down menu from the Delete Sheets command. 

 

Figure 6.2 Select sheets for deletion. 

2. After the items for deletion are selected, click “Delete” and then “Yes” on the subsequent two dialog 
boxes. Close out of the dialog box when finished. 



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 21 

 

Figure 6.3 Deleting Sheets confirmation dialog box. 

 

Figure 6.4 Un-check the items on the “Bid Items” worksheet confirmation dialog box. 

The item MQ worksheets will be deleted and will appear as follows on the “Bid Items” worksheet. 

 

Figure 6.5 “Bid Items” worksheet after deleting sheets. 

Delete the Unit Price from the bid items before re-filtering the items; that way, if the item is later 
reinserted, the old price will not get accidentally used. 

Deleting the quantities and unchecking an item does not prevent it from appearing in 
reports and exports. The item MQ worksheet must be deleted with Delete Sheets to be 
fully removed.   
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7. Combining Multiple Bid Items into One Table 

7.1 Before You Combine Items 
Before entering quantities into the MQ worksheets, it is best to combine the like items into summary sheet 
tables. Q2P can only use one individual bid item worksheet as a template for the summary sheet table, so any 
data entered onto non-template worksheets will not carry over to the summary sheet (i.e. Using a template 
worksheet that only has CAT 0010 quantities to combine items with CATEGORY 0030 quantities will not display 
any CATEGORY 0030 quantities on the new combined sheet. To add a missing category total to the item 
worksheet you want to use as the template, see 8.1.3 Adding/Deleting Categories). 

It is very important to keep all the quantities for an item in one table only (i.e. do not have 
“Sawing Asphalt” combined with “Removing Asphaltic Surface Butt Joints,” and also 
combined with “Asphaltic Surface Driveways and Field Entrances.” Q2P’s macros do not 
allow for this, but it would be possible to manually set that up. Delete any data that was 
entered into an MQ worksheet that has been combined (other than the category totals) 
so it is clear to other users of the file where the most up-to-date information is located.  

It is good practice to set up all the item MQ worksheets categories BEFORE combining them onto a summary 
sheet because adding or deleting categories on the summary sheet requires links to be recreated. Run ADD-
INS > Data > Update Quantities… whenever deleting categories from an item worksheet. 

7.2 Combined Summary Sheets 
1. Select ADD-INS > Data > Combine/Add Related Items… or use the right-click menu for launching the 

dialog box.  

 

Figure 7.1 Launching the combining items dialog from the right-click menu. 

2. Enter a name that starts with three numbers, then a hyphen, and then a description that uses text 
and hyphens so the worksheet tab will be placed next to the associated bid items, and fill out the rest 
of the information to describe the combined summary sheet.  
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Do not start the combined summary sheet name with text, or use any symbol other than 
a hyphen, otherwise the worksheet may show up on the Cost Report as an item with no 
quantity or cost, or end up in the export file.  

An Excel worksheet name cannot exceed 31 characters, be blank, or contain any of 
the following characters  \ / : ? * [ ]. A Q2P Combined Summary Sheet is further limited 
to no special characters (other than hyphens in the name), and cannot end with the 
combination of a hyphen and only the letter C (e.g. –c). 

3. Select “Create Summary Sheet.” If the button is grayed-out, click into a different field in the dialog 
box to refresh it. 

 

Figure 7.2 Combining items dialog for creating Summary Sheet. 

4. Once items have been combined onto a summary sheet, format your tables by adding the item names, 
changing the title, changing text color, centering, etc. and begin entering quantities into the table 
(Figure 7.3). 

 

Figure 7.3 Example of formatted table to be displayed on MQ Plan Sheets. 
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7.3 How Totals are Linked 
The following screenshots show how the item totals are the sum of the row entries from the combined 
summary sheet, which is linked back to the total cell on the individual item worksheet, which is then linked 
back to the main “Bid Items” worksheet, via the “Name”. 

1. The example “Clearing” item sum calculated: 

 

Figure 7.4 Combined summary sheet. 

2. On the individual worksheet for the “Clearing” item, note the TOTAL201.0105_0010 Name is still set 
on this page, but the total itself is a link to the combined summary sheet. The 99999 quantities entered 
here in the example do not affect the Q2P quantity for “Clearing”: 

 

Figure 7.5 Individual miscellaneous quantity worksheet that has been combined. 

(Note that quantities can still be entered, but will not be reflected because the sum is a link to the combined summary sheet and not the 
current worksheet.) 
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The “…(DON’T INCLUDE THIS SHEET ON THE PLAN)” note is a reminder that this 
worksheet should not be linked to the PowerPoint miscellaneous quantity sheet file, 
since the data is not live updating with the engineer’s estimate or the combined 
summary sheet (other than category total). 

3. On the “Bid Items” worksheet, the total quantity for “Clearing” is determined by the Name 
TOTAL201.0105_0010 in the workbook. If there was more than one category, the Names would be 
totaled: 

 

Figure 7.6 The total item quantity on the Bid Item worksheet is linked to the total of the category Names. 

(In this example, there is only one category.) 

Since the quantities are obtained from the item Name, the individual item worksheets 
should not be deleted after a summary sheet is created. Otherwise, the cell reference 
links on the summary sheet will break. (See Chapter 9, Deleting an Item from a Combined 
Summary Sheet for the preferred method.) 

4. If categories are added/deleted from the combined summary sheet, select ADD-INS > Data > Re-
Establish Links Between Summary Sheet and Related Items or run this command from the right-click 
menu. 

 

Figure 7.7 Right-click menu to re-establish inks. 



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 26 

8. Entering and Computing Quantities 
Once all the miscellaneous quantity worksheets (MQ sheets) have been inserted into Q2P and items combined 
as appropriate, enter the quantity information. Use the space to the right of the “REMARKS” column to 
calculate quantities as needed. 

It is important to use the =Round (<formula>,0) function to properly round the results 
of a formula. If cell formatting is used instead, then it is possible that when summed 
on paper, the individual quantities will not add up to the total. 

 

Figure 8.1 Example of how ROUND makes formula results add up correctly on paper. 

For example, format the cell for locating new passing zones and permanent signing to always show two 
decimals. See FDM 19-5-5.7.3 for guidance on rounding quantities.  

Do not rename or delete the “Bid Items” worksheet, and never enter quantities on the 
main “Bid Items” worksheet. Always enter the quantities on the MQ sheets. If quantities 
are entered in the “Bid Items” worksheet and the Update Quantities command is run, all 
the entries will be lost and replaced with a link to the total on the associated worksheet. 

Q2P utilizes SUM to create the category totals, and this function will only add numbers. If a unit is included in 
the same cell as the quantity (e.g. “4887 CY” or “33’” instead of “4887” or “33”) it will be ignored. Enter station 
as the whole number (without the “+”) to be able to use them in calculations.  

  

http://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
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8.1 Important Formatting Rules 
You can use simple Excel functions to format the rows, columns, and cells to display the data as it will be 
shown in the construction plan miscellaneous quantity sheets, but it is important to maintain some spatial 
relationships between certain cells. Before you start heavily formatting, see the following sections for 
important rules to follow.  

8.1.1 “Total 00X0” Cell 
The “TOTAL 00X0” text must contain that exact content and format (i.e. TOTAL 0010, TOTAL 0020, etc.). 
Changing it to “TOTAL 10,” for example, will cause errors (<Error - CHECK CATEGORY NUMBERS>). Q2P 
creates the Excel cell Name and a SUM based on this spatial relationship and that Name is how the 
quantity is referenced in various reports, outputs, and the main “Bid Items” worksheet. 

 

Figure 8.2 Source of bid item category sum Name. 

If these Names or links are inadvertently deleted or otherwise corrupted, running ADD-INS > Data > 
Update Quantities… will recreate the links (for only the categories included in the list on the bottom of 
the “Bid Items” worksheet). The “CATEGORY” listed in column A is optional text for the miscellaneous 
quantity sheets and does not affect calculations. 

8.1.2 Multiple Categories 
If multiple categories are used for the item, then a “Project Total” must also be shown on the plan sheet 
table, which is a manually created sum of the category totals.  

 

Figure 8.3 Project Total. 
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8.1.3 Adding/Deleting Categories 
Delete unused category rows (using Excel commands) from the individual MQ sheets. Do not keep empty 
Cat. 0020, 0030 totals on the worksheet (unless intended to be used at a later time), otherwise the 0 
quantity/cost will appear in the Cost Report and the upload file to Trns•port/AWP Preconstruction.  

To add additional categories to the MQ sheet, copy and paste the text and formatting of a category name 
and total that is already on the item worksheet and place them in the same columns. Then select ADD-
INS > Data > Update Quantities… > Update One Item to create the proper links for that particular item, 
or use Update All Items to update all items at once, which may take longer to process. 

8.1.4 Item Number and Unit Links  
Links to the item number and item unit must be in the same column as the category sums (Figure 10.3). 
If this relationship is lost, the “Bid Items” worksheet quantity will show an error 
(<Error - CHECK CATEGORY NUMBERS>) and the first category in the column will not appear in outputs. 

 

Figure 8.4 Bid item number and unit must remain in the same column as the SUM formula. 
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8.2 Formatting Text 
ADD-INS > Format in Q2P contains various tools for formatting text. The most useful format change is for 
forcing the station value to display two decimals. Excel formatting will insert the “+” for you (i.e. Enter 
“12345.05” to display as “123+45.05”). 

8.3 Pay Plan Quantity 
If it is desired to pay plan quantity for an item (FDM 19-5-5.7.2), then right-click and select “Pay Plan Quantity.” 
The bid item name will be appended with “**P**” and a check box appears for toggling it off. 

 

Figure 8.5 Pay Plan Quantity on miscellaneous quantity worksheet. 

The setting can also be changed by right-clicking on the item in the “Bid Items” worksheet list. 

8.4 Recording Computations 
Being able to have the quantity calculations done right alongside the location data is one of the advantages 
of using Q2P to create MQ plan sheets. 

 

Figure 8.6 Typical computations. 

When quantity calculations are completed in Q2P, it is very easy to see how a change in milling thickness, for 
example, will affect project cost. If the change must be made after the miscellaneous quantity plan sheets are 
created, the computations will carry-through all the way to the PowerPoint sheets, and only the PDF output 
needs to be recreated. 

8.5 Row Tracking 
While entering information on larger combination worksheets, it can be difficult to keep track which row is 
being edited. The ADD-INS > Data > Highlight Row command will create a helpful visual aid. 

 

Figure 8.7 Highlight Row in use. 

http://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
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9. Deleting an Item from a Combined Summary Sheet 
1. Copy the appropriate rows/columns of data back to the individual item worksheets so that data is not lost 

when unlinking all items.  

2. Select the ADD-INS > Data > Combine/Add Related Items… command. 

3. Select an existing summary sheet; select one of the associated items; click the “Unlink” button that 
appears after an associated item is selected.  

 

Figure 9.1 Unlinking items from the summary sheet. 

9.1 Unlinking Causes Performance Issues 
When a bid item is unlinked from a Summary Sheet, occasionally some garbage data gets inserted into 
row 1,048,576. This causes performance issues in the file, which is visible when you examine the file size 
and see that it has increased significantly. This is more immediately noticeable when the scroll bar on 
the right side of the summary sheet becomes very small.  

As a workaround (until the bug can be fixed), select all the rows (down to the very end) under the 
worksheet’s visible data and right-click delete. When the file is saved, the scrollbar should appear normal 
again.  



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 31 

10. Establishing Unit Prices 
Unit prices are entered on the “Bid Items” worksheet and are always entered into Q2P as present day costs 
without inflation. Inflationary cost increases are typically applied just prior to the October 1 FIIPS snapshots. 
Unit prices and quantities are also verified at all Life Cycle changes and PMP phase changes. 

Commonly used sources for item prices include: AASHTOWare Project Estimator™; comparable, nearby and 
recent projects (via Bid Express® or bid tabs); averages from WisDOT Central Office Structures; and WisDOT 
Regional Technical Services staff for pavement pricing trends. More details can be found in the WisDOT 
Facilities Development Manual 19-5-5 Estimating Guidelines. Bid item average price is not appropriate to use 
at PS&E, but can be acceptable earlier in design. 

Do not change the prices of bid items that are highlighted as pre-established price items. 
These are typically incentive, on-the-job training, and SPV items (with DOL or HRS units). 
Enter prices to the nearest cent. The SPV.0055 and SPV.0075 items are normally pre-
established price items, but can be bid normally depending on the item details. Pay special 
attention to these two items. 

Always update the date in Q2P to reflect quantity and/or unit prices revisions. 

  

http://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
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10.1 Exporting from Q2P into AASHTOWare Project Estimator™ 
1. Select ADD-INS > Unit Price Resources > Run ESTIMATOR. 

This command will create a temporary file for import (and launch Estimator for WisDOT staff). 

This command is used to transfer items and quantities into Estimator for obtaining 
the bid regression prices. It is NOT used to create a complete Estimator file for use 
with Trns•port/AWP Preconstruction. As such, all quantities will be imported into 
Estimator under one category (10). 

2. Once the import file is created, follow the instructions in the “Estimator Help” dialog box as shown in 
Figure 10.1. 

 

Figure 10.1 Importing Q2P into Estimator help. 

3. Verify the project total in Estimator matches the construction cost total in Q2P. 

4. Select and highlight the estimate total. 

5. To use the bid regression/average prices in Estimator, select Edit > Update Price Information: Restart. 
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10.2 Important Estimator Information 
• After restarting an estimate, most items will have a bid regression based price, but some items will 

have a $0.00 ad hoc price, and SPV items will receive a bid regression/average price that is completely 
inappropriate since the item details are unknown to Estimator. Look out for these prices. 

• Any item with a supplemental description (and therefore likely a .01, etc. added to the bid item 
number) will always be stuck at ad hoc in Estimator until the extra numbers are removed.  

Typically users should not be relying on bid regression prices for any item that 
requires a supplemental description as by definition they are unique and cannot be 
bid under a “standard” bid item, but those prices can be a good start or reassurance 
for a price, especially early on in the project lifecycle. 

 

Figure 10.2 Item with supplemental description. 

Estimator will show a blank description in the left pane and ad hoc price source, when the extra 
decimal and numbers are included in the item number. 

 

Figure 10.3 Estimator view of an item that has been imported, that has a supplemental description. 

Estimator will also show blank item descriptions for item numbers that are not in the 
catalog, therefore the Export to Estimator tool in Q2P can be used to check older Q2P 
files for items that may have been retired since their initial selection. 

Once the item number is corrected, the item description loads on the left, and the bid regression price 
loads on the right. 
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Figure 10.4 Estimator view once the extra digits and decimal have been deleted from the item number. 

• Importing into Estimator can sometimes cause an Excel process to hang. Therefore, it is recommended 
that you save your file prior to making the export to Estimator. Also, none of the data in Estimator has 
a live link to Q2P, so the process must be repeated with quantity or item changes. 

• If the user has data past column Z, and it has a number in row 12, that will cause errors for Estimator 
during the import. Move the number up out of row 12 in the Q2P file, or delete those columns entirely 
in the TEMP-ESTIMATOR-IMPORT file. 
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10.3 Importing from AASHTOWare Project Estimator™ into Q2P 
1. In Estimator, select FILE > Export… and name the file ESTIMATOR-EXPORT.xlsx and save to the 

C:\Q2P\Temp\ directory. Do not edit this file. 

2. In Q2P, select ADD-INS > Unit Price Resources > Copy Prices from Another Project.  

This command will replace any existing notes, data, etc. that is currently in column K on 
the “Bid Items” worksheet. Before running this command, verify column K is empty. 

 

Figure 10.5 Warning message. 

3. Select the file that was exported from Estimator (named by date and time) and select “Open.”  

The prices from Estimator will load into column K and will be rounded to the nearest 
cent, therefore if all the Estimator prices are used in Q2P, the project totals will likely 
differ by a small amount. 

4. Rename the column K heading to something like the date of the Estimator run. Otherwise, in the 
future, that data might be mistakenly used when transferring data to/from Estimator, instead of the 
current Q2P unit prices.  
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10.4 Copying Unit Prices 
1. From the “Bid Items” worksheet, filter the items to only show “X.” 

2. Select the first cell down from K12 (i.e. the first unit price from Estimator) and use Ctrl + Shift + Down 
Arrow to select the range. 

3. Un-filter the Q2P item list and use Ctrl + C to copy the prices in column K. 

4. Select the first cell with a price in the Q2P unit price column F. 

5. Right-click > Paste Special… and use Paste: Values, Operation: None, and Skip Blanks settings. 

6. Select “OK.” 

Note that by completing the above steps, price data for items that are not currently used 
in the Q2P project will be deleted. (A user may delete an item out of Q2P, but keep the 
price information in case the item is reinserted at a later date. By copying all Estimator 
prices over, those retained prices will be lost.) 

10.5 Copying Q2P Items into Bid Express® 
1. Select ADD-INS > Unit Price Resources > Letting Reports. 

This command creates a temporary file that contains a comma delimited list of all the Q2P bid items 
currently marked with an “X” (for items with and without corresponding worksheets created), and 
copies that list to the clipboard. Follow the instructions on the dialog box for pasting the item list into 
Bid Express. 

 

Figure 10.6 Bid Express help. 

7. To edit the list of items before pasting into Bid Express, edit the TXT file and then copy/paste.  

SPV items are not searchable by bid item number because each number can refer to 
completely different items based on the project.  
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11. Viewing “80/20 Rule” Items for Documenting Unit Price Sources 
WisDOT construction projects typically adhere to the Pareto principle and have 80% of their total contract 
cost generated by about 20% of the total items. Therefore, it is important to focus on these items the most 
when creating the engineer’s estimate and then document the basis for the unit price. This documentation 
will aid others who may work on the project and/or be indispensable when responding to a justification 
request after project let. The documentation can be as simple as including a note off to the right of Column K 
in Q2P for the items and should detail the bid item unit price estimate source, such as: nearby, similar projects 
(IDs); Bid Express; Estimator; regional trends; or a combination of these. Also, state whether or not one bidder 
was assumed for the project. 

Items that fall outside the 80/20 rule can still end up being “significant items” and therefore require careful 
consideration and should be documented, especially if they have a history of price fluctuation. 

11.1 CAUTION! 
Do not use the Excel Sort command on the “Bid Items” worksheet.  

Sort will only automatically expand the selection to data that is contiguous to the original selection. It will not 
automatically expand the selection when run from an AutoFilter drop-down, even if the data is contiguous. 
Sort also changes the row number of each line, but only does so within the AutoFilter group and does not 
extend past column G in Q2P. This means if Sort is used from the filter drop-down, any price information 
stored off the to the right of “Cost” will be out of order relative to the rest of the data. Item worksheets will 
contain incorrect links as these do not auto-update when using Sort. 

Use either of the following workflows in 11.2 or 11.3 to view the “80/20 Rule.” 
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11.2 Using a Number Filter 
1. Use the “Top 10…” Excel Number Filter. 

 

Figure 11.1 Filter drop-down selected in “Cost” cell. 

2. Change to Top | 20 | Percent. 

 

Figure 11.2 Top 10 AutoFilter changed to “Top 20 Percent.” 

The “Bid Items” worksheet is now filtered on the top (by value) 20% of the items. 

 

Figure 11.3 View of “Bid Items” worksheet data that has been filtered by “Top 20 Percent.” 
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3. Highlight the group of “COST” total cells to display the total of the filtered Cost. Excel displays the sum 
of a selection on the bottom right of the status bar. For this example, the top 20% of items is equal to 
about 95% of the total project construction cost. It isn’t necessary to re-filter the list down to an exact 
80% of project cost – just be aware that these are the items that require the most scrutiny when 
developing the engineer’s estimate and require some level of price documentation. 

 

Figure 11.4 Using the selection sum feature of Excel. 

4. Select the filter drop-down in the “Cost” cell again to clear the Number Filter. 

 

Figure 11.5 Filter drop-down, used to clear the Number Filter. 
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11.3 Using Conditional Formatting 
1. Highlight all the cells in G12:G2187 (match the actual range of Costs).  

2. Select HOME > Styles panel > Conditional Formatting > Top/Bottom Rules > Top 10%... 

 

Figure 11.6 Conditional Formatting Excel command. 

3. Set the conditional formatting to 20% along with the desired highlighting. 

 

Figure 11.7 Top 10% Conditional Formatting dialog box. 

Now all Costs can be viewed at the same time, with the top 20% items highlighted. 

 

Figure 11.8 Bid items with the higher Cost items highlighted as they are included in the top 20%. 
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The formatted cells will change as new items are added to the project, or existing prices are revised. 

 

Figure 11.9 Bid items with item 204.0115 Cost no longer highlighted as the unit price was revised down. 

Use a Number Filter to quickly sum these top 20% items to verify that 20% is still the appropriate 
value to use for delineating the items that total around 80% of project cost. This should be done 
especially when major changes have occurred to the project estimate. 

4. To clear Conditional Formatting, use HOME > Styles > Conditional Formatting > Manage Rules… 
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12. Creating the Miscellaneous Quantity Plan Sheets 

12.1 Setting up the Power Point Slide Template 
1. Open a new Miscellaneous Quantities plan sheet template, titled 030200_mq.potx, found in the 

C:\Q2P directory. There is also a rotated plan sheet template for use as needed. 

 

Figure 12.1 PowerPoint sheet template launch icon. 

2. Save the PowerPoint sheet working file in the same directory as the project’s Q2P workbook working 
file and name it 030200_mq.PPTX. It should remain there until after PS&E. 

Remember to never save project files in C:\Q2P because updates will rewrite the files 
stored in this directory. 

3. Fill in the project title block information. This is done by editing the “Slide Master.” Go to VIEW > 
Master Views > Slide Master. 

 

Figure 12.2 Normal View. 
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Making edits to the “Slide Master” will translate those edits to be used on all sheets. 

4. Click on the Slide Master #1 and then edit the text boxes at the bottom of the plan sheet. 

 

Figure 12.3 Slide Master View. 

Note that there is a second master slide which is blank. This can be used to create a 
second sheet, if different project information is required within the same PPTX file. 

5. When finished, click the “Close Master View” button. 

6. In Normal view, use HOME > New Slide to create multiple copies of the slide as needed to 
accommodate the Q2P miscellaneous quantity data. 
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Figure 12.4 PowerPoint New Slide. 

12.2 Copying Data onto PowerPoint Slide 
1. In Q2P, highlight the range of data to be included on the plan sheet.  

2. Select PAGE LAYOUT > Print Area > Set Print Area.  

3. Right-click + Copy or select HOME > Clipboard > Copy to copy the selection. 

Q2P works best when a Print Area is linked to PowerPoint since this allows users to 
insert rows and columns and have those changes reflected in PowerPoint. If only a 
cell range is selected, rows will shift out of view when new ones are inserted into the 
table. Alternatively, Use FORMULAS > Defined Names > Define Name, to break-up 
worksheets that must span two PowerPoint sheets. 

4. In PowerPoint, select HOME > Clipboard panel > Paste drop down menu > Paste Special… and select 
the “Paste link” radio button. Choose “Microsoft Office Excel Worksheet Object”.  
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Figure 12.5 Paste Special in PowerPoint. 

Make sure the “Display as icon” checkbox is NOT checked. 
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5. Use the right-click menu > Format Object to scale to a standard percent for the sheets, or set the 
insertion point manually if attempting to align multiple items. 

 

Figure 12.6 Right-Click Menu 

 

Figure 12.7 Format Object dialog box. 

Note that “Lock aspect ratio” needs to be checked. 
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6. Use the standard PowerPoint tools to create lines (HOME > Drawing) to separate items. 

 

Figure 12.8 Drawing lines in PowerPoint. 

Holding the shift key while creating or lengthening a line will lock in the direction to 
90°/180°/270°/360. 

Once miscellaneous quantity worksheets are linked to PowerPoint, the XLSM file should not be moved or 
renamed, as links are not relative, they are absolute. Under the FILE > Info > Related Documents > Edit 
Link to Files, the links may be reviewed for problems and file source locations manually updated for each 
link, one at a time, if necessary. 

 

Figure 12.9 Use “Edit Links to Files” to review links between Q2P and PowerPoint. 

Always have the associated Q2P workbook open BEFORE opening the PowerPoint MQ 
plan sheets. This will avoid extremely slow processing due to PowerPoint needing to open 
and close Excel to update every link in the file. 
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12.3 Printing the Miscellaneous Quantity Sheets 
The MQ plan sheets must conform to the standards in FDM 15-1-30, Miscellaneous Quantity Sheet. Use the 
following steps to create the PDF file from PowerPoint for the final electronic plan (ePlan). 

1. Select FILE > Print and set the Printer to “Adobe PDF” and verify “All Slides” are to be printed. 

2. Click “Printer Properties” to access the Print dialog box. 

 
 

 
 

Figure 12.10 Accessing printer properties. Figure 12.11 Basic Print Settings for Adobe PDF. 
 

  

3. Set “Adobe PDF Page Size” to 11 x 17. 

4. Change the “Layout” to Landscape and hit “OK.” 

 

Figure 12.12 Layout changed to Landscape. 

5. Select “Print” and save the PDF as 030200_mq.pdf in the SheetsPlan\pdf folder. 

http://wisconsindot.gov/rdwy/fdm/fd-15-01.pdf
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13. Print Project Cost Report 
The Cost Report is the engineer’s estimate, grouped by category.  

1. Prior to creating a Cost Report, use ADD-INS > Project > Checked By… and enter the appropriate initials 
and date. This information will appear on the Cost Report footer. 

2. Select ADD-INS > Print > Estimate… > Print Full Estimate (Formatted) to print the project cost report 
which displays the estimate totals by category. This command automatically prints as a PDF. Alternatively, 
the main “Bid Items” worksheet can be printed from the standard Excel print dialog to disregard 
categories and just view the item costs across all categories. 

 

Figure 13.1 Q2P Cost Report. 

Note the zero quantity in CATEGORY 0020 for traffic control. This category was incorrectly left on the 
traffic control MQ worksheet.  

Delete unused category rows (using Excel commands) from the MQ worksheets and run 
ADD-INS > Data > Update Quantity… > Update One Item to refresh the links to the main 
“Bid Items” sheet. 
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Figure 13.2 Item worksheet with unused category left in place. 

A miscellaneous quantity worksheet must only contain the categories that are 
required. Do not keep empty CATEGORY 0020, 0030 totals on the worksheet (unless 
intended to be used at a later time), otherwise the 0 quantity/cost will appear in the 
Cost Report and the upload file to Trns•port/AWP Preconstruction. 

The Print Category Costs Summary command creates a useful report for completing a Project Change Request 
for updating FIIPS. This command outputs to a Microsoft® Word document. 
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14. Creating the Upload File for Trns•port® 
This command may take several minutes to finish and is best run from a fresh session of Q2P. 

Prior to creating the upload file for Trns•port, verify all empty categories are deleted from 
each miscellaneous quantity worksheets, otherwise 0 quantities will appear in the file 
(See Category 0020 in Figure 13.1). 

1. Select ADD-INS > Export Estimate > Create Pjiport.xml file. 

 

Figure 14.1 Work Type and additional header information dialog box. 

2. Select the proper “Work Type” from reviewing the descriptions, or by consulting with the region project 
manager. The “Total Cat” should automatically match the number of categories on the bottom of the “Bid 
Items” worksheet. Select your “Region” from the dropdown menu and select “OK.” 

If an empty dialog box appears and does not load the options shortly thereafter, using Esc 
will usually resolve the issue. 

 

Figure 14.2 Empty dialog box – hit “Esc” on keyboard if encountered. 
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The resulting Pjiport.dat file is a simple text file and can be opened and reviewed with any text editor. 

 

Figure 14.3 Example Trns•port PES upload file. 

3. Manually review the Pjiport.dat file for completeness and/or errors prior to uploading into Trns•port PES. 
Pay special attention to the items with supplemental descriptions. 

Note how the Item Description from Q2P is not actually exported to Trns•port. Rather, it is populated in 
that system from the item number. 

For instructions on uploading the Pjiport.dat file into Trns•port PES, see FDM 19-5, Exhibit 10.5, Uploading 
Project from Estimator to Trns.port PES. The help documentation refers to the pjiport.dat file originating from 
Estimator, but the Q2P version is also a valid source. 

  

http://wisconsindot.gov/rdwy/fdm/fd-19-05-010e005.pdf
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15. Creating the Upload File for AASHTOWare Project Preconstruction™ 
This command may take several minutes to finish and is best run from a fresh session of Q2P. 

Prior to creating the upload file for AWP Preconstruction, verify all empty categories are 
deleted from each miscellaneous quantity worksheets, otherwise 0 quantities will 
appear in the file (See Category 0020 in Figure 13.1). 

1. Select ADD-INS > Export Estimate > Create XML Estimate File.  After selecting the command, a window 
will appear that informs you that a pass file for upload into AWP Preconstruction will be created and 
asks if you want to continue.  Select “Yes” to continue.   

 

Figure 15.1 Pass file creation confirmation dialog box. 

2.  Select the proper “Work Type” from reviewing the descriptions, or by consulting with the region 
project manager. The “Total Cat” should automatically match the number of categories on the bottom 
of the “Bid Items” worksheet. Select your “Region” from the dropdown menu and select “OK.” 

If an empty dialog box appears and does not load the options shortly thereafter, using 
Esc will usually resolve the issue. 

 

Figure 15.2 Empty dialog box – hit “Esc” on keyboard if encountered. 

 

Figure 15.3 Work Type and additional header information dialog box. 
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The resulting XXXX-XX-XXToPrecon.xml file is saved by default in C:\Q2P\TEMP.  XML files will open up 
with Internet Explorer by default and looks similar to Figure 15.4.  

 

Figure 15.4 Example AWP Preconstruction pass file. 

4. Manually review the XXXX-XX-XXToPrecon.xml file for completeness and/or errors prior to uploading 
into AWP Preconstruction. Pay special attention to the items with supplemental descriptions. 

Note how the Item Description from Q2P is not actually exported to AWP Preconstruction. Rather, it is 
populated in that system from the item number. 

For instructions on uploading the XXXX-XX-XXToPrecon.xml file into AWP Preconstruction, see FDM 19-5-10, 
Uploading Project from Estimator to AWP Preconstruction. The help documentation refers to the XXXX-XX-
XXToPrecon.xml file originating from Estimator, but the Q2P version is also a valid source. 

http://wisconsindot.gov/rdwy/fdm/fd-19-05.pdf
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 APPENDICES 

Appendix A.       Troubleshooting 

A-1       “########” Displays in a Cell 
When a cell in Excel does not have sufficient width to display the entire number, it will display a cell filled 
with “#”. Increasing the width of the column will fix the issue. 

 

Figure A-1 Insufficient column width. 

Double-clicking in the area between columns headings (columns I and J in our example) will automatically 
change the width to an amount that will allow all content to display properly. Excel will do this when the 
mouse cursor has changed to the Excel “resize column width” cursor. 

 

Figure A-2 Resize column width cursor. 

You can also right-click on the column name (I) and select “Column Width…” to change the width to a set 
larger value.  

 

Figure A-3 Right-click menu for accessing the “Column Width…” command. 
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A-2       “#REF !” Appears in the Quantity Total on the main “Bid Items” Worksheet 
This error occurs most often when a category has been deleted from an MQ worksheet. The solution is to 
update the item by using right-click + Update Item… which will create the proper links. You can also do 
this by selecting ADD-INS > Data > Update Quantities… to update all items at once. 

 

Figure A-4 Fixing error with Update Item. 

A-3       Bid Item Number Loses Trailing Zeros When Cell is Edited 
The bid item number cells on the main “Bid Items” worksheet must be formatted as “Text,” not “General.” 
If they are formatted as “General” they will appear normal until a cell is entered into for editing. Once 
edited, the trailing zeros will be lost and the number will change to right aligned. Cell formatting can be 
changed by selecting the cells, and then via Home > Number Panel > Drop-down, change the format from 
“General” to “Text.” You can also right-click + Format Cells… to access the same menu. 

A-4       Combine/Add Related Items… Command is unavailable in Data Menu 
If the Combine/Add Related Items… command is unavailable in the Data menu, use Project > Refresh 
Toolbar to reload it.  If this does not work, close and reopen the Q2P file.  Note that this command will 
not be available if the Q2P file does not have any individual MQ worksheets in it. 
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A-5       Compile Error 
A compile error is typically due to ActiveX controls not being properly installed and registered. This 
happens because the Q2P directory was incorrectly copied over to a workstation rather than being 
installed from the Q2P package. Verify Q2P was properly installed with the DOT Computer Help Desk. 

 

Figure A-5 Compile error warning message. 

A-6       Cost Report Errors 
If the Cost Report created from Print > Full Estimate (Formatted)… generates a “CONSTRUCTION COST 
ESTIMATE” that differs from the one on the main “Bid Items” worksheet, Q2P will recognize this error and 
highlight it on the costs report. This occurs when an item has the category changed and the ADD-INS > 
Data > Update Quantities… command does not complete the task properly, leaving the old category total 
values as duplicates. 

 

Figure A-6 Error highlighting under CATEGORY 0010 in the Cost Report. 

 

Figure A-7 Error highlighting under CATEGORY 0030 in the Cost Report. 

 

Figure A-8 Message on bottom of Cost Report referencing aforementioned error. 

The fix is to manually remove duplicates from Q2P by using the FORMULAS > Name Manger and then 
deleting the “TOTAL<item-number_category-number>” that is causing the issue. There may be other 
Names starting with “Unit”, “Print_Area”, “Description”, etc. that are broken as well (names with #REF! 
values or references), but they do not need to be deleted for the Cost Report to generate correctly. 

mailto:DOTITServiceDesk@dot.wi.gov
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Figure A-9 Deleting duplicate entries in Name Manager. 

Other Cost Report errors and fixes include the following: 

 

Figure A-10 Other Cost Report errors. 

 

The “workbook’s estimate” refers to the “Bid Items” worksheet. If this error occurs, navigate down the 
Quantities column on the “Bid Items” worksheet to see if one contains too many decimal places. 
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A-7       Macros Fail to Load 
If the Q2P macros fail to load when the workbook is opened, check that the Q2P-Macros.XLAM file is 
located in the C:\Q2P directory. 

To manually un\load Q2P-Macros, use the “Add-Ins…” command. This command is no longer in the default 
toolbars/ribbon but can be added to the Quick Access Toolbar by using FILE > Options > Quick Access 
Toolbar. 

Choose commands from: All Commands. Select “Add-Ins…” and Add >> OK. 

 

Figure A-11 Adding a button for Excel Add-Ins. 

The “Add-Ins” dialog box can also be accessed via FILE > Options > Add-Ins > Manage: Excel Add-Ins > 
Go… 

 

Figure A-12 Excel Add-Ins manager. 
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A-8       Paste via Right-click Causes Q2P to Freeze 
When selecting and copying multiple rows or columns in Q2P and then pasting via the right-click menu 
into a single row/column, Q2P will freeze. 

There are many workarounds to avoid this issue, and they all require the user to not use the right-click 
menu when pasting. Therefore, Ctrl+V; HOME > Clipboard > Paste; or hitting Enter will all work without 
problems. 

If the right-click menu is used to paste in this situation, hitting Enter immediately after the paste will 
complete the paste, or if still frozen, then hitting F12 and then Cancel on the next dialog box will resolve 
the issue. 

A-9       Right-click Menu for Q2P Disappears 
If the right-click menu items disappear from Q2P, use ADD-INS > Project > Refresh Toolbar to reload them. 
If this does not work, close and reopen the Q2P file. 

A-10       Small Triangles Appear in Cells 
If “Error Checking” is enabled in Excel, then small triangles will appear in cells when it believes there is an 
error (such as the multiple leading zeros in category numbers, etc.). 

 

Figure A-13 Excel error checking displaying small triangles in cells – will also display in PowerPoint. 

 

To stop Excel from displaying these error triangles, select FILE > Options > Formulas. Then under “Error 
Checking,” unselect “Enable background error checking”. 
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Figure A-14 Disabling Excel error checking. 

A-11       Sort via Right-click or the AutoFilter Drop-down Causes Q2P to Freeze 
Do not use the “Sort” command from any of the Excel menus. Instead, use “Conditional 
Formatting” and/or “Number Filters” to review the 80/20 rule items. If you wish to view 
the data in a particular order (e.g. largest to smallest to include in the estimate 
documentation), copy the data onto a new workbook prior to sorting and use that new 
copy for manipulating. 

If the Sort command is used from the right-click menu or from the AutoFilter drop-down on the “Bid 
Items” worksheet, Q2P will freeze after completing the sort. To make Excel responsive again, hit “Enter” 
or try hitting F12 and then “Cancel” on the next dialog box. The freeze can be avoided by using the Sort 
commands found on the DATA > Sort & Filter panel.  

Use EXTREME caution if you decide to Sort the data as sorting is known to cause errors in 
Q2P. 

  



Quantities 2 Plans User Guide 

Wisconsin Department of Transportation 62 

A-12       “Trns•Port” or Other Application Installer Dialog Box Appears 
• If an unrelated application installer dialog box appears when first loading the macros or selecting a 

macro related object in Q2P, immediately select “Cancel”. 

 

Figure A-15 Installer dialog box. 

Users may need to “Cancel” several times if the dialog continues to pop up. 

If the installer is allowed to finish before cancel is selected, an invalid source message will appear. 

 

Figure A-16 Installer error. 

Q2P will operate fine after the dialog is cancelled, but WisDOT staff should notify DOTQ2P of the issue 
and contact the DOT Computer Help Desk for a reinstall of Trns•port if the problem persists.  

• When some of the ADD-INS > Print > Estimate… > commands are run, the following error can pop-up: 

 

Figure A-17 Converter error. 

This error can be ignored. 

mailto:dotq2p@dot.wi.gov
mailto:DOTITServiceDesk@dot.wi.gov
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Appendix B.       Miscellaneous Helpful Information 

B-1       Getting Help  
Request help with Quantities 2 Plans by contacting the region Q2P power users in your office found here 
or by sending an email to DOT Q2P Support. If the issue is believed to be more of a general problem with 
Excel or PowerPoint, WisDOT staff should contact the DOT IT Service Desk. 

B-2       Excel® Tips and Tricks 
• To bypass automatic formatting of data in a cell, insert an apostrophe in front of the data. 

• To quickly flip though worksheets, use Ctrl + Page Up/Down. 

• Excel will only sort data that is contiguous to the initial selection. Also, even if the data is contiguous, 
it will not sort outside of an autofilter group. 

• The N function can be repurposed for inserting comments into formulas. Using it will add 0 to the end 
of the formula, as the N function generally converts text (other than TRUE) to 0. This is cleaner than 
using Excel comments as it will not show a red triangle in the cell. Append a formula with: 

+ N(“This is the comment”) 

B-3       Complex Formulas 
In addition to relatively simple computations, more complex formulas can be written. 

One common reoccurring issue with permanent signing MQ sheets is that stop signs have their SF 
calculated from the entered length X width (with a simple unrounded formula such as “=U9*W9/144”), 
rather than octagonal area. The correct value from the sign plate can be used by using a lookup table: 

=IF(K9="R1-1",VLOOKUP(U9,tables!$B$7:$C$14,2,FALSE), 
IF(K9="ZX-X",VLOOKUP(U9,tables!$B$79:$C$86,2,FALSE), 
IF(ISNUMBER(SEARCH("M",K9)),"-", 
IF(ISBLANK(K9),"", 
ROUND(((U9*W9)/144),2))))))))) 

 

 

Figure B-1 Excerpt from tables worksheet. 
(Lookup array highlighted) 

http://wisconsindot.gov/Pages/doing-bus/eng-consultants/cnslt-rsrces/tools/estimating/est-q2p.aspx
mailto:DOTQ2P@dot.wi.gov
mailto:DOTITServiceDesk@dot.wi.gov
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Additional formulas can be used to show category subtotals on the “Bid Items” worksheet. 

For CATEGORY 0010, with the quantity to be reported in column N: 

=IF(A13<>"x","",IF(ISERROR(INDIRECT("TOTAL"&B13&"_0010")),"<CAT>",(INDIRECT("TOTAL"&B
13&"_0010")))) 

For CATEGORY 0010 cost: 

=IF(A13<>"x","",IF(N13="<CAT>","<CAT>",IF(ISERROR(D13),0,IF(D13="",0,IF(D13=" 
",0,IF(D13="<Error>",0,F13*N13)))))) 

Adjust the red values for each category/location. These formulas can cause slowdowns in Excel with larger 
projects. 

It is important to always build a formula that other users will be able to understand. That 
might require using individual cells that are labeled for both variables and constants. 

Other formulas can be written with Excel for computing incentives, etc. 

Q2P users are encouraged to submit their custom formulas or workflows to DOT Q2P Support, so they can 
be added to the User Guide or otherwise shared. 

  

mailto:DOTQ2P@dot.wi.gov
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B-4       Revising Security Settings 
To avoid the security prompts, the Q2P application directory can be added as a trusted location. Also, 
certain settings should be verified if Excel will not load the macros. 

1. Open FILE > Options > Trust Center > Trust Center Settings…. 

 

Figure B-2 Trust Center. 

2. Click on the “Trusted Locations” tab. 

 

Figure B-3 Adding a Trusted Location. 

3. Make sure that “Allow Trusted Locations on my network (not recommended)” is checked. 
4. Click on the “Add new location…” button. 
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Figure B-4 Specifying the Trusted Location. 

5. Click the “Browse…” button and navigate to C:\Q2P 

 

 

Figure B-5 Browsing to the Q2P directory. 

6. Click “OK.” 

 

Figure B-6 Including subfolders in the Trusted Location. 
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7. C:\Q2P should be listed. Check “Subfolders of this location are also trusted” and click “OK.” C:\Q2P 
should now be in the list of trusted locations, user locations. 

  

Figure B-7 Verifying Q2P was added to Trusted Locations. 

8. Click the “Add-ins” tab and make sure the settings are as listed below. 

 

Figure B-8 Verifying Q2P Add-in settings. 

9. Click the “ActiveX Settings” tab and make sure the settings are as listed below. 

 

Figure B-9 Verifying ActiveX settings. 
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10. Click the “Macro Settings” tab and make sure that the settings are as listed below. 

 

Figure B-10 Verifying Macro settings. 

11.  Click the “External Content” tab and make sure that the settings are as listed below. Click “OK.” 

 

Figure B-11 Verifying External Content settings. 

12. Click “OK” again to close the dialog box. 

Verify all these settings if having issues with links to other workbooks. 
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B-5       Editing the Hidden Q2P Template 
It is strongly recommended for users to not edit the miscellaneous quantity worksheet 
template by un-hiding the appropriate worksheet in Excel. This method of editing the 
template has been known to cause significant issues such as deleted category totals 
appearing in the Cost Report. As such, the workflow is unsupported; however, if the 
template has been edited and problems are encountered, the User Guide section on Cost 
Report Errors should help resolve them. 

Editing the MQ worksheet template will yield the best results if it is done only once, before any items 
have been created. The issues get worse if it is edited after it has been used to create worksheets. 

Once the MQ worksheet template is open, unwanted categories can be deleted, rows and columns can 
be added, resized, etc. and those changes will be pushed to subsequently created bid item worksheets. 

1. To unhide the template worksheet, use ALT+F11 to launch the Microsoft Visual Basic window. 

2. In the VBAProject tree, select the “Sheet6 (MiscellaneousQTYSheet D5).” 

 

Figure B-12 Visual Basic window. 

3. Under the Properties, change the “Visible” setting from “2 - xlSheetVeryHidden” to “-1 – 
xlSheetVisible” by clicking and selecting from the dropdown.  

4. Then in Visual Basic, use File > Close and Return to Microsoft Excel. The worksheet template 
(named “MiscellaneousQTYSheet D5”) will now be visible for editing.  
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Typically, some standard REMARKS are added, or the LOCATION is entered as the highway.  

 

Figure B-13 Editing the template in Excel. 

B-6       Creating Comp Sheets 
Once the bid items have been selected, WisDOT form DT2138 “Design/Final Computations” sheets can be 
generated, if desired, through ADD-INS > CompSheets > Create Computation Sheets for ALL the Marked 
Items “x” or Insert One or More Computation Sheets. 

These worksheets are not linked to the MQ worksheets and are not intended for users to do quantity 
calculations on them. They are provided to automate the task of entering the Project No., Item, etc. 
information on paper comp sheets. Only create these comp sheets if paper copies are desired for sketches 
or other written records. 

B-7       Making Notes in Q2P 
The columns past column G (except for column K) can be used to make notes about any particular item. 
Unit price source information and tagging the items in the FIIPS Preliminary Quantities groups are the 
most common notes recorded in Q2P. 

Column K must be avoided as the command for importing prices from Estimator will 
overwrite this column. Also, keep the Color Code legend in column H intact. 
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Figure B-14 Making notes in Q2P. 

The commonly used abbreviations for FIIPS Preliminary Quantities (Roadbuilder Quantities) are:  

ASPH (Asphalt Pavement TON), CONC (Concrete Pavement SY), EXCV (Excavation CY), BCRS (Base Course 
TON), BRDG (Bridge SF), MILL (Milling SY), GRND (Diamond Grinding SY), STRP (Pavement Marking LF), and 
RUBL (Rubbilized Pavement SY). Obviously some quantities need to be converted to the correct unit of 
measure prior to being totaled for entry into FIIPS. 

The notes can serve as the required documentation of how unit prices were arrived at for the engineer’s 
estimate (for the 80/20 rule items). When making notes about unit price sources, be sure to include a 
general project statement as to whether or not “one bidder” was assumed. 

B-8       Finding Contingency Let Dates in FIIPS 
The Earliest Possible Let is obtained from the FIIPS. These are considered to be Priority 1 advanceable and 
have the PS&E submitted early. Priority 2 code projects are ones that are the top region priority for 
advancement and C.O. may request the PS&E package as needed. The regions may also have priority 10 
contingency projects that don’t have early lets in FIIPS and are just kept for regional balancing due to 
individual project delays, etc. rather than statewide program issues or unbalanced lettings. 

Find the earliest possible let in FIIPS by checking Project > Estimate… and view the LET project information. 
If the “Earliest schedule date” differs from the “Schedule date” then the project is a priority 1 contingency 
and must be submitted early. PMP should have the base schedule set to the earliest date and the project 
developed accordingly. 

This contingency date can be manually added to Q2P, above the PSE Date field, if the designer finds that 
information helpful to display.  
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Appendix C.       Confidentiality of Engineer’s Estimate and Pre-award Bid Data 
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Appendix C (continued) 
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